Labb 1: GNS3-nätverk

Det är faktiskt inte lätt att “hacka” något nätverk. Man ska själv kunna nätverk, programmering och databas på avancerad nivå, man ska ha speciella program eller system, exempelvis Wireshark och Kali Linux (Penetration Testing Distribution) bland flera många till.

För att kunna utforska de olika attackmetoder bygger vi här ett virtuellt nätverk. Det gör vi delvis i VirtualBox och delvis i GNS3. Vi kommer att behöva flera Host-Only nätverk som ska användas i VirtualBox och GNS3, alternativt Microsoft loopback nätverkskort (interface).

Host-Only nätverk

I nätverkstopologin används två cloud-enheter i GNS3, LAN och ISP. Dessa cloud-enheter konfigureras i ett Host-Only nätverk, var och en i ett separat Host-Only nätverk. Ett sådant nätverk skapas automatiskt vid installationen av VirtualBox. Som default skapar VirtualBox ett Host-Only nätverk och då behöver vi skapa ett till manuellt.

För att ta fram [Nätverks- och Internetinställningar] ska du exempelvis högerklicka på den ikonen, längs ner till höger, som representerar det trådlösa nätverket.

Bild 1: Nätverks- och Internetinställningar

Det öppnas ett nytt fönster med varierande inställningar. Du klickar på [Ethernet] i spalten till höger och därefter klickar  du på [Ändra nätverkskortsalternativ]

Bild 2: Ändra nätverkskortsalternativ

Det öppnas ett nytt fönster som visar de olika nätverksanslutningar datorn har. Till exempel min dator visar följande:

Bild 3: Nätverksanslutningar

För att skapa fler Host-Only nätverk ska du

  1. klicka på [Tools] i VirtualBox Meny
  2. klicka på [Create] och skapa två Host-Only nätverk
Bild 4: Skapa fler Host-Only nätverk

Nya Host-Only nätverk får ett numrerade namn samt en IP-adress och aktiverat med DHCP. Se till att IP-konfigurera Host-Only nätverk #2 enligt bilden nedan. Host-Only nätverk #3 behöver du inte göra något åt (IP adressen 192.168.137.1 sätts automatiskt)

Bild 5: Flera Host-Only nätverk

Nätverkstopologi

Här nedan en bild som beskriver nätverkstopologin vi ska jobba med:

Detaljer för virtuella maskiner i VirtualBox

  • kalixtos är en Linux virtuellmaskin i VirtualBox, RAM-minne på 2048 GB, hårddisk på 50 GB
  • kalixtos virtuellmaskin har för nätverksadapter Host-Only #2
  • kalixtos IP-adress är 192.168.2.10 /24, default gateway 192.168.2.254
  • winser är en virtuellmaskin i VirtualBox med RAM-minne på 2048 GB och en hårddisk på 25 GB
  • winser virtuellmaskin har för nätverksadapter Host-Only #2
  • winser kör Windows server 2012 R2 eller 2016
  • winser kör IIS med grundinställningar och en hemsida som kan kännas igen
  • winser har för IP-adress 192.168.2.11 /24 och default gateway 192.168.2.254
  • wincli är en virtuellmaskin i VirtualBox med RAM-minne på 1024 GB och hårddisk på 20 GB
  • wincli virtuellmaskin har för nätverksadapter Host-Only #2
  • wincli kör Windows 7 eller 10
  • wincli har för IP-adress 192.168.2.12 /24 och default gateway 192.168.2.254

Detaljer för virtuella maskiner i GNS3

  • LAN är ett moln som har för nätverksadapter Host-Only #2
  • ISP är ett moln, kör DHCP server, har för nätverksadapter Host-Only #3
  • R1 är en 3600 router som använder två FastEthernet interface
  • R1 fa0/0 ansluts till LAN Host-Only nätverk #2
  • R1 fa0/0 IP-konfigureras med adressen 192.168.2.254 /24
  • R1 fa1/0 ansluts till ISP Host-Only nätverk #3
  • R1 fa1/0 konfigureras som DHCP klient (ip address dhcp, ip domain-lookup, ip name-server 8.8.8.8)
  • R1 kommunicerar med ISP via en default route anslutet via 192.168.137.1
  • R1 konfigureras med en Access List som tillåter LAN 192.168.2.0 /24 NAT kommunikation med ISP
  • R1 fa0/0 konfigureras som ip nat inside
  • R1 fa1/0 konfigureras som ip nat outside

Konfigurationer

Efter att GNS3 har installerats behöver importeras IOS images och justera funktionalitet i GNS3. Det kan man göra på olika sätt exempelvis via inställningar. Klicka på [Edit]och välj [Preferences].

Ett annat sätt är att välja [IOS images and Supervisors]

Det öppnas [Preferences] och har ska man först klicka på IOS routers i spalten till vänster. Därefter på [New] i spalten till höger. Detta förutsätter att du har IOS images lagrade lokalt i någon mapp.

 

Det är nu du anger sökvägen till Cisco IOS image. Klicka på [New Image], ange sökvägen och därefter klicka på [Next]

Nu anger du RAM-minnets storlek och hur dina konfigurationer lagras i NVRAM. Se till att du har samma inställningar som på bilden nedan:

 

Se till också att routers nätverksadapter väljs enligt bilden nedan. Nu är routers IOS på plats, klicka på [Idel-PC-Finder] ifall det inte startas automatiskt. Denna funktion söker anpassade exekveringsmiljö just för router 3600.

Nu ska du skapa ett nytt projekt. Klicka  i menyraden på File och därefter på [Ny blank project]. Namnge projektet som Attack-network:

Denna nätverkstopologi ska kopplas ihop med några virtuella maskiner i VirtualBox. Det kan vi göra på olika sätt, exempelvis importera i GNS 3 virtuella maskiner från VirtualBox eller bara ansluta virtuella maskiner från VirtualBox till Cloud-enheter. Det är detta som vi kommer att göra och inte importera virtuella maskiner.

Nu bygger du upp ett nätverk i vilket ska utforskas olika attackmetoder. På spalten till vänster klicka på ikonen som representerar routrar. Då kommer du se routrarna som du har installerat. Markera router c3600 och dra till arbetsytan. Routern namnges direkt som R1.

Nu drar vi två cloud-enheter, en till vänster och en till höger om R1. Klicka på ikonen som visar flera nätverksenheter och dra en cloud två gånger.

 

  1. Högerklicka på Cloud 1 och välja [Change hostname], ange namnet LAN och tryck på Enter. Därefter dra etiketten till molnet.
  2. Gör det samma med Cloud 2 som ska få namnet ISP

För att virtuella maskiner i ett Host-Only nätverk ska ha Internetanslutning ska vi aktivera Internetdelning genom att högerklicka på Wi-Fi nätverksanslutning, egenskaper, Delning. ISP cloud-enheten har som interface Host-Only #3 och detta interface ska kopplas till Wi-Fi så att den kan ha Internetanslutning.

 

Du hittar denna anslutning i Nätverks- och Internetanslutningar tillsammans med de två Host-Only nätverksadaptrar.

 

 

DI GNS3 högerklicka på Cloud 1 som har namn LAN. Klicka på [Configure]. Nu visas ett fönster [LAN configuration] där du ska konfigurera:

    1. markera de olika interfaces som visas, ta bort de och aktivera [Show special Ethernet interfaces].
    2. klicka på pilen nedåt och välj Hos-Only Network #2 och klicka på [Add]
    3. Markera interfacet Hos-Only Network #2 och klicka på [Apply]
    4. Klicka på OK

  1. Nu ska vi ansluta samman LAN --> R1 --> ISP
  2. För att starta R1 kan du klicka i Menyraden på den gröna pilen, eller högerklicka på R1 och klicka på [Start]

  • Högerklicka nu på R1 och därefter klicka på [Custom console]
  • Interface konfigurationer
  • R1(config)# interface fa0/0
  • R1(config-if)# description To LAN
  • R1(config-if))# ip address 192.168.2.254 255.255.255.0
  • R1(config-if))# no shut
  • R1(config-if))# interface fa1/0
  • R1(config-if)# description To Internet
  • R1(config-if))# ip address dhcp
  • R1(config-if))# no shut
  • R1(config-if))# end
  • R1# show ip int br
  • Default route
  • R1(config)# ip route 0.0.0.0 0.0.0.0 192.168.137.1
  • NAT konfiguration
  • R1(config)# access list 1 permit 192.168.2.0 0.0.0.255
  • R1(config)# ip nat inside source list 1 interface fa1/0 overload
  • R1(config)# interface fa0/0
  • R1(config-if)# ip nat inside
  • R1(config-if)#interface fa1/0
  • R1(config-if)# ip nat outside
  • R1(config-if)# exit
  • DNS konfiguration
  • R1(config)# ip domain-lookup
  • R1(config)# ip name-server 8.8.8.8